RPG-XML Suite 3.3x System Requirements

Installed Feature Requirements

  • RPG-XML Suite requires Apache which is installed on 99% of all machines we come in contact with. Note that Apache only needs to be started if you are offering web services from your IBMi. If you are only acting as the client role and making a request to another server from the IBM i, then you don’t need to start the Apache server.
  • We use QShell during the install so that is also required and is already installed on most machines. It is 5722SS1 opt 30.

Operating System Level Support

RPG-XML Suite can be used on the following operating system versions:

  • IBM i OS 7.4
  • IBM i OS 7.3
  • IBM i OS 7.2
  • IBM i OS 7.1
  • IBM i OS 6.1