System Requirements

Operating System Level Support

Payment Terminal Toolkit for i can be used on the following operating system versions:

  • IBM i OS 7.3
  • IBM i OS 7.2
  • IBM i OS 7.1

In order to handle the required cryptography, PTTi relies on the system having a recent version of OpenSSL installed.

Our development is performed against OpenSSL 1.0.2j which was made available in the following PTFs: